USA and Canada - Delivery Receipt Latency
Incident Report for Nexmo
Resolved
This incident has been resolved.
Posted 14 days ago. Apr 06, 2019 - 03:17 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 14 days ago. Apr 06, 2019 - 02:07 UTC
Investigating
We have been informed by one of our suppliers about an issue impacting delivery receipts in the U.S. and Canada. Our customers might experience delays with receiving delivery receipts when requested.

Please note that SMS MT/MO messages are not affected by this issue.

Our suppliers have identified the issue and are working to restore normal delivery speeds as soon as possible. We will keep you updated on any progress.

Please contact support@nexmo.com if you have any questions.
Posted 14 days ago. Apr 05, 2019 - 22:34 UTC
This incident affected: SMS API (North America (US, Canada & Caribbean) traffic).