SMS delivery to US & Canada
Incident Report for Nexmo
Resolved
This incident has been resolved.

If you are still experiencing problems, please kindly contact support@nexmo.com
Posted 4 months ago. Jun 21, 2019 - 06:54 UTC
Monitoring
Please be informed a fix has been implemented and SMS messages are now being processed without delay. We are monitoring the quality closely.

If you are still experiencing problems, please kindly contact support@nexmo.com
Posted 4 months ago. Jun 21, 2019 - 06:03 UTC
Investigating
Please be advised that due to local issues with our suppliers in US, we have been experiencing message delivery issues to US & Canada since 21-JUN-2019 02:30 UTC.
We are working on resolving these issues and will update when we have more information.
Posted 4 months ago. Jun 21, 2019 - 04:02 UTC
This incident affected: SMS API (North America (US, Canada & Caribbean) traffic).