Service Degradation
Incident Report for Nexmo
Postmortem

What happened

We experienced an outage of the Nexmo dashboard and website from 13:49 UTC to 14:03 UTC, due to an issue with our CDN provider. Customers trying to access these resources would have received 502 errors.
The issue also impacted customers who were using geo-specific endpoints such as api-us1/2.nexmo.com, rest-eu.nexmo.com.
We implemented a workaround at 14:11 UTC by removing our CDN provider's CNAME records from our DNS records for the above-mentioned resources. The CDN provider fixed the underlying issue at 14:15 UTC which then resolved the issue for all nexmo.com affected hostnames.

Causes

The issue has been caused by the problem on our CDN provider's side.

Preventive Actions

A program of preventive work has been identified, including:

  • Improved failover actions and policies
  • Improved monitoring and alerting
Posted 4 months ago. Jul 05, 2019 - 15:18 UTC

Resolved
The issue has been fully resolved.

Please let support@nexmo.com know if you continue to experience problems with this.
Posted 4 months ago. Jul 03, 2019 - 09:13 UTC
Monitoring
We experienced an outage of the Nexmo dashboard and website from 13:49 UTC to 14:03 UTC, due to an issue with our CDN provider. Customers trying to access these resources would have received 502 errors.
The issue also impacted customers who were using geo-specific endpoints such as api-us1/2.nexmo.com, rest-eu.nexmo.com.
We implemented a workaround at 14:11 UTC by removing our CDN provider's CNAME records from our DNS records for the above-mentioned resources. The CDN provider fixed the underlying issue at 14:15 UTC which then resolved the issue for all nexmo.com affected hostnames.
Posted 4 months ago. Jul 02, 2019 - 14:39 UTC
This incident affected: Voice APIs (See https://goo.gl/2WoAtx for Current known problems) (Voice API) and Nexmo Dashboard, Website, [Beta] Messages API.