SMS delivery to Argentina - Movistar (722070)
Incident Report for Nexmo
Resolved
This incident has been resolved.
Posted 8 months ago. Apr 04, 2018 - 02:01 UTC
Investigating
Please be advised that due to local issues with our suppliers in Argentina, we have temporarily lost reach to Movistar (722070).
Posted 8 months ago. Apr 03, 2018 - 20:29 UTC