SMS delivery to Estonia 24802
Incident Report for Nexmo
Resolved
This incident has been resolved.
Posted 2 months ago. Jun 12, 2017 - 17:48 UTC
Investigating
Please be advised that due to local issues with our suppliers in Estonia , we have temporarily lost reach to Elisa(24802).

We are working on resolving these issues as soon as possible and we will post any updates here.
Posted 2 months ago. Jun 11, 2017 - 20:35 UTC
This incident affected: SMS API (Outbound SMS, Europe traffic).