SMS delivery to MCI Iran (43211)
Incident Report for Nexmo
Resolved
This incident has been resolved.
Posted 3 months ago. May 10, 2018 - 17:19 UTC
Investigating
Please be advised that due to local issues with our suppliers in Iran, we have temporarily lost reach to MCI Iran (43211).
Posted 3 months ago. May 10, 2018 - 16:04 UTC