Service Issue with customer dashboard
Incident Report for Vonage API
Postmortem

Date/Time Impacted

2021/07/08 09:18 UTC until 2021/07/08 15:38 UTC

Services Impacted

Customer Dashboard

Summary

Some links on the Dashboard returned HTTP 404 errors when attempting to reach them.

Root Cause

On July 8 2021 at 09:18 UTC we deployed some minor changes to the back-end for our customer facing dashboard that caused a select few URIs to return HTTP 404 errors when requested directly. At 15:38 UTC a subsequent deployment was made to resolve these URI errors.

Restoration Action

Dashboard deployment was rolled back to previous version to prevent further errors while issue was investigated.  The issue was resolved and the updates have now been deployed successfully.

Next Steps

We will be implementing additional monitoring and testing processes to ensure that we catch this kind of issue in future deployments.

Posted Jul 22, 2021 - 10:04 UTC

Resolved
This incident has been resolved. We have seen no further errors while monitoring.
Posted Jul 08, 2021 - 16:24 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 08, 2021 - 14:44 UTC
Update
We are continuing to investigate this issue.
Posted Jul 08, 2021 - 14:35 UTC
Investigating
We are experiencing some intermittent issues with page loading on the API Dashboard resulting in some pages not being found and 404 errors being generated. The engineering team are investigating and we should have this issue resolved shortly.



Please see this article - https://help.nexmo.com/hc/en-us/articles/360015693092-Nexmo-Incident-Handling - for an explanation of our approach to publishing incidents.
Posted Jul 08, 2021 - 14:35 UTC
This incident affected: Nexmo Dashboard.