Voice API and WebRTC call failures - London Data Center
Incident Report for Vonage API
Postmortem

What happened

On February 26th at 15:46 UTC, we started routine maintenance in our London data center. At 15:47 UTC, customers began to experience issues starting new Voice API and WebRTC calls, and the inability to control in-progress calls. Our engineering team were alerted to the issue at 15:48 UTC and restored all services at 15:53 UTC. This issue impacted Voice API and WebRTC calls only - Messaging, SIP and WebSocket traffic did not experience any impact. 

Causes

During routine maintenance, a bug in our deployment software caused a segment of voice services in our London data center to enter a failed state.

Preventive Actions

Upgrade deployment software.

Improve routine maintenance testing and scheduling processes.

Posted Mar 05, 2021 - 12:21 UTC

Resolved
We experienced an issue impacting Voice API and WebRTC calls processed in our London Data Center.

Customers may have experienced issues starting outbound calls and receiving inbound Voice API and WebRTC calls. In-progress calls were not impacted.

Services were impacted from 2021-02-26 15:46 until 2021-02-26 15:53

All services have been restored.

Please let support@nexmo.com know if you continue to experience problems with this.
A post-mortem will be published in the next few days.
Posted Feb 26, 2021 - 16:42 UTC
This incident affected: [Beta] In-App IP communications ([Beta] In-App IP Voice) and Voice APIs (See https://goo.gl/2WoAtx for Current known problems) (Voice API).