www.nexmo.com experiencing problems
Incident Report for Nexmo
Resolved
This problem is now resolved. Our team continues to monitor closely.
Posted 22 days ago. Sep 30, 2019 - 02:15 UTC
Investigating
Our website www.nexmo.com experienced a technical problem between 00:46 and 02:09 UTC - 30th September 2019.

This problem is now resolved. Our team continues to monitor closely.
Posted 22 days ago. Sep 30, 2019 - 02:15 UTC
This incident affected: Website.