WhatsApp Delivery Issues
Incident Report for Vonage API
Postmortem

What happened

On Sep 20th, 2020 05:15 UTC, some of our customers sending outbound WhatsApp Messages via our Messages and Dispatch APIs experienced message failure. These messages would have failed with an "undeliverable" status. This continued until 05:35 UTC when we fixed this. 

Causes

An automated database patch caused our database to malfunction. This stopped our platform from properly processing Whatsapp traffic. 

Preventive Actions

We're working on disabling automated patching for our database. 

We're also working on improving our alerting system so we can detect issues like this sooner.

Posted Sep 30, 2020 - 08:33 UTC

Resolved
This incident has been resolved.
Posted Sep 20, 2020 - 06:34 UTC
Monitoring
We have experienced issues with WhatsApp messages not being delivered for some customers between 05:15 and 05:35 UTC. The issue has been resolved and we are currently monitoring the results. Please reach out to support@nexmo.com if you have any further questions.
Posted Sep 20, 2020 - 05:58 UTC
This incident affected: [Beta] Messages API.