SMS delivery to Philippines - Sun Cellular (51505)
Incident Report for Nexmo
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 08, 2017 - 00:29 UTC
Investigating
Please be advised that due to local issues with our suppliers in the Philippines, we have temporarily lost reach to Sun Cellular (51505).

We are working on resolving these issues as soon as possible and we will post any updates here.
Posted 4 months ago. Jun 07, 2017 - 17:43 UTC