SMS, Voice API and Messages API- Callbacks and messages delayed
Incident Report for Vonage API
Postmortem

What happened
At 08:10 UTC on May 13th, 2020, customers started having issues with Outbound and Inbound SMS delayed for a number of European carriers.
In addition, at 08:37 UTC, Voice API and Messages API callbacks for requests processed by our European datacenters started to be missing.
A fix was applied at 08:56 UTC but the Messages API callbacks continued to be delayed for a few more minutes as we were reprocessing the queues.

Causes
Misconfiguration in the VPN tunnels used to integrate with our partners.

Preventive actions
Improvements to our test suite to cover a wider variety of VPN settings and catch mistakes before going to production.

Posted May 19, 2020 - 11:21 UTC

Resolved
We have completed monitoring of the incident, and haven't detected any further issues. Please let support@nexmo.com know if you continue to experience problems with this. A post-mortem will be published in the next few days.
Posted May 13, 2020 - 14:30 UTC
Monitoring
We have experienced an issue causing delays in SMS callbacks as well as SMS delayed and missing Voice API callbacks from 08:20 to 08:56 UTC. There has also been a delay in Messages API callbacks and inbound messages until 09:11 UTC. We have applied a fix and we're currently monitoring. The impact is limited to Europe.
Posted May 13, 2020 - 09:43 UTC
This incident affected: SMS API (Outbound SMS, Inbound SMS, SMPP, Europe traffic), [Beta] Conversation ([Beta] Conversation API), Voice APIs (See https://goo.gl/2WoAtx for Current known problems) (TTS API, Voice API, Europe Traffic), and [Beta] Messages API, [Beta] Dispatch API.